Ubuntu上にVagrant環境構築

最近困っていたUbuntu上にVagrantをインストールしたけど全然Vagrant up出来ない現象を解決。

There was an error while executing `VBoxManage`, a CLI used by Vagrant for controlling VirtualBox. The command and stderr is shown below.

みたいなエラーが出ている場合、
VirtualBoxのバージョンを上げるだけで解決することもあるのでやってみたところ解決した。

まずは前のバージョンのを消しちゃいます。

$ sudo apt-get remove --purge virtualbox* 
$ sudo rm ~/"VirtualBox VMs" -Rf 
$ sudo rm ~/.config/VirtualBox/ -Rf

そして現時点で一番新しいVirtualBoxを入れてみる。
https://www.virtualbox.org/

$ sudo dpkg -i virtualbox-5.2_5.2.2-119230_Ubuntu_trusty_amd64.deb

これで解決。

コメントを残す